Monday, 12 November 2018

I moved to AMD Platform part 5

I have my AMD computer up and running with all the drives connected, fresh, and ready to work. Except the graphics card driver that had been released the same day as my installation I did not install any other drivers.

I did not use the DVD of drivers that  came with my ASUS mother board. I did not need it. Windows 10 had taken care of everything. Why should I stuff my smoothly silent working computer with things. I closed both sides of the computer case (the habit that I never had, being used to leave them open) I put all the noise dampers back on their places and look when you enter the room you cannot recognise a computer is working there.

My phone immediately was found by the Windows, no waiting for the drivers to be installed and trying to find your ways through the forums and manufacturer sites, etc.

They have made things easy these days! Of course out of bad intention! Why? There was a time that as the user of a PC gradually you would become a nerd that could understand what was going under the hood. Then you could find ways around the ad ware spy ware and puffery promises and so on. When you feel you do not need to learn then gradually you become a sheeple that sits and consumes every rubbish like the golden time of TV. TV and news papers with loads of rubbish are back but now on computers with much more power turning the society into a more individualistic way. and at last we have smart TVs. They are actually computers that cannot be tweaked even by most committed nerds.

Now it was the time for installing the Oracle Virtual Box where after adding my Windows 7 x64 I found a new problem. I had no problems with my Linux virtual boxes, though.

I need this Windows 7 virtual as I do my Visual Studio on it.and it is full of my codes. I kept my Windows 7 RTM DVDs when I moved to the Windows 8. But used them to create two virtual boxes one for 32 bits and one for 64 bits Windows 7.

I also use these virtual boxes when some dodgy producers offer free software etc. I download them on virtual boxes and test if suddenly on  using them they act as bait and switch and solicit you to buy a key to see the miracles of the software or when I found them bloatware or other unwanted undesirable behaviours.

Now on first turn on of Windows 7 64 this message came out:

"Your PC uses a processor that is designed for the latest version of

Windows. Because the processor is not supported together with the

Windows version that you are currently using, your system will miss

important security updates."


AMD (and also Intel and Qualcom)  have decided that to leave the support for the Windows 7 and also Windows 8.x in favour of Windows 10. This is consistent with the Microsoft model described earlier; supposedly not releasing a new version of Windows.

If you are interested you can read about this policy change here: Windows 10 Embracing Silicon Innovation.

As we know, Microsoft will push this model forward and individual resists for a while and gradually market will accept it. It is not bad or evil. It is planned by scores or even hundreds of highly skilled, and experienced programmers and operating system developers. (Well, with cues from marketing people and perhaps other layers behind the scene.)


If I had a Windows 7 on my AMD platform as the main (host) operating system and insisted to keep it due to certain reasons, then it could be a great problem. But for me it is just a guest on the virtual box. I can close the warning, ignore it and continue work until the next booting of the machine.

As I will explain under another title on a virtual machine I am not concerned about the security threats. I always have a clone of the machine and if something bad happens I delete the infected machine and reboot in the cloned machine. Virtualisation is partly for this.

I did not want to throw away my Windows 7 DVD's and buy a Windows 10 for my virtual machines.

Happily, more enthusiast people have found a solution. You can delete the file that does not support the new hardware for the security update and use the patch that has been created by this bright enthusiast computer expert at GitHub here:  Disables the "Unsupported Hardware" message in Windows Update, and allows you to continue installing updates on Windows 7 and 8.1 systems with Intel Kaby Lake, AMD Ryzen, or other unsupported processors. 

I used the patch and updated my virtual Windows 7.

Conclusion: As I do not play games and do not develope them and also do not edit videos routinely my AMD Rayzen 7 2600 and X470 platform with its stock cooler is enough for me. I have thrown away all the stupid extra fans and all the home made led lighting that I had. I have a silent well behaving computer with enough power for my C/Java coding, maintenance of my websites and other works. My powerful Graphics card is also beyond the power necessary for watching even in 4k. As I already had case PSU and graphics card it also did not bring much expenses. (I gave my older parts still with a good life time remaining to the charity of cats to sell on eBay). I might buy a glass window for my Thermaltake case to enjoy RGB of motherboard.

Friday, 2 November 2018

I moved to AMD Platform part 4


Then I turned the computer and disconnected it physically from the main. I connected Blu ray and two of the hard disk drives.

I did  not attach all hard drives then, out of being cautious. I have seen things. We all are sleeping at night and when we wake up in the morning there are new realities and new idea in place without being notified. We have to sign and accept at the bottom of small fonts without understanding what is going on and we like to be amused by toys we have bought from them.

“For God’s sake, let us be men
not monkeys minding machines
or sitting with our tails curled
while the machine amuses us, the radio or film or gramophone.

Monkeys with a bland grin on our faces.” 

D.H. Lawrence, Selected Letters

Hence, we might enter into the unchartered waters and we need some patience.

I powered the computer and immediately right click on  the start button and selected the disk manager utility to open it.

But lo and behold! Panic seized me: one of the most important partitions of newly attached disks was labelled as "Recovery healthy partition" a total of 1 TB. It contained all my codes, backup of my websites and many other goodies. It did not also appear on the My Computer" Windows

Many thoughts came to  my mind. For instance I am used to label partitions with Greek alphabets instead of Latin and I load my costume made icons with them - such as lambda theta etc. The lost partition had a combined name "PsiPhi" to be pronounced as Sci-Fi. and its icon was also combined letters, ψφ.  Perhaps this was the reason.

I also change letters Windows uses for enumerating partitions. I do not like when Windows start from the letter 'D' and then 'E', 'F', 'G' etc. I use X, Y, Z, U, v, W and so on. the lost partition was always labelled as X. As Windows installation has its own use of letter X and Z I became suspicious that this could be the cause. (These letters are something related to the OS and are not engrave into the hard drives. so no worries about this)

Well, happily it is a rule that when Windows become confused and label a partition it is just a label and should be corrected.

I opened a command prompt as administrator and typed "diskpart" (without quotation marks, of course - to the end of this article) to open the application for examining the partitions.

On the diskpart prompt I typed  "list disk" and tapped the  "enter" key. A list of my drives (now two of them) came.

Next I typed "select disk 1" and entered. Disk 1 is the disk that contains my ψφ partition. 

Then I typed "list partition" and entered. A list of partitions come on the command. Voila! here is my lost partition It is not primary as it should it is described as the "Recovery"

I select the "Recovery" partition to examine it by typing "select partition 1" and enter.

After selecting the desired partion I examine its properties by typing "determine partition", or briefly, "det par"  nd enter.  You can see that a description of the lost partition comes in the next lines. 

For the first time label of the partition is shown correctly as "psiphi." But there are differences between this and a primary partition first its type id is "27" instead of "07" second, there is no letter attributed to it and at last under the "info" column it is described as "hidden."

please note that you might find hexadecimal numbers for the recovery type de94bba4-06d1-4d40-a16a-bfd50179d6ac that could be changed or set to the primary type ebd0a0a2-b9e5-4433-87c0-68b6b72699c7. 




(As I had to go back and forth between OS and BIOS and I was a bit in an uneasy state due to disappearance of the partition I did not take snapshots and used the camera on my mobile phone to take the pictures, so the previous picture is patched with the mobile phone pictures.)

I need to chang the "type : 27"  id to "type : 07" id, everything then will be back to normal. Even if you delete a partition you can undelete it easily but you should not be tempted to fiddle with things on your own such as formatting the deleted partition or writing things on it that make reversing the situation more difficult.

Now as the partition is already selected, I type "set id=07" and enter. To check if the partition is back to primary I type "det par" again and enter.  I can see the changes have been done.



No letter is attributed, but the volume number is also has changed from "12" to "3". It does not appear in "My Computer" until you attribute a letter to it. I opened the "Disk Management" utility and find it as the "primary" partition with no letter. I select a letter for it (my favourite X) and see that now it appears in "My Computer" too.


Thursday, 25 October 2018

I moved to AMD Platform part 3

Besides other preparations I downloaded the latest driver for my graphic card (ASUS Strix). By Chance it had been released a few days before my download.

Having everything prepared, I connected power and fans to the motherboard. I connect all SATAs before installing graphic card. It is possible to connect them after but it is a bit difficult with the big graphic cards on your way. I disconnected SATAs from all SATA devices.

Also I disconnected Power from PSU to SATA's. I do not like to have power on the devices when they are not connected. I have this habit from the ancient time when we would not turn on HiFi devices when no speakers were connected to the audio outputs. It could be an obsession but sometimes gut feeling cautiousness is what one needs to follow rather than promises of other engineers.

There is a new mistake regarding recent on board graphics output on AMD boards. One can use them when he has installed the right, graphic supporting AMD CPU's are installed. As far as I know none has come to the market yet. Some people on the idea that there is such a facility available do not attach any graphics card and voila: three beeps from the BIOS as the sign of "no graphic cards!"

Even with those processors the video does not enjoy what you might love to have. Perhaps they are good for the organisations computers and workstations. They use a share part of your RAM's for graphic processing - some 2GB. Right now I have not any judgement about those builds and how far they are useful for Video editing or watching HD, 4K etc. For gaming definitely they do not satisfy those gamers who use two cards each with 11 GB DDR5.

Then I connected graphic card, keyboard, and mouse, and broadband. I turned on the computer and entered BIOS by pressing "Delete" key. In BIOS I checked that CPU, memories, and above all the WD M2 SSD and mouse and broadband were fully recognised.

In BIOS upgrade menu you can see the option to upgrade it through the internet but I prefer to use the memory stick for that job.

I turned off the computer and connected the flash memory stick that contained the BIOS upgrade to its latest version. I turned it on again and followed the procedure for upgrade. Happily, BIOS had recognised the existence of the memory stick with upgrade and did it smoothly through it.

I turned off the computer again removed the BIOS update memory stick and attached the Windows 10 memory stick and turned the computer again. I entered the BIOS and asked it to boot through the memory stick.

Windows 10 installation software on the flash memory without any error recognised the WD Green M2 and completely installed Windows 10.

This is the latest version of Windows 10 with all updates and everything. I can be sure that it dos not need any driver or software accompanied on the DVD of your motherboard. This is the new policy of Microsoft. No future version of Windows is promised. Windows 10 is the last version of Windows and Microsoft will only updates it constantly and all previous versions will become obsolete similar to DOS and Windows 3 and so on.

Most people know how to follow from this point on. You can skip the activation key and password setting etc. But a new idea as the PIN has been introduced in expectation of uniformity with portable devices such as Surface, mobile phones, BYODs and such. You have to do that. Do not disturb smooth installation by trying to avoid this. Later after logging to your Windows and checking everything you can remove it if you like.

After I opened my Windows for the first time, I ejected the memory stick and removed it from the USB. Immediately I connected the graphics card USB and installed "just drivers". I do not like that at this stage, to install software that later constantly ask me things or producing hurdles that I should search forums for their answers and solutions.

I went to the activation in control panel and activated my Windows through the key that I had acquired from Microsoft.

I restarted my Windows. I did a thorough clean up. and disk optimisation and again restart (after clean up some temp files will only be deleted through the restart at the reboot stage.

Then I followed the procedure to create an image backup of the entire activated  but yet untouched Windows. This job needs a 32GB memory stick which is now under £8.





Wednesday, 24 October 2018

I moved to AMD Platform part 2



In new build I got rid of the Corsair H115i liquid cooler that I had and also all the decorating LED's etc. I did not need to cool down my Intel 2011 6 cores extreme with 150 watts TDP.

I also removed my Sandisk 512 GB SSD. I noticed that maximum I use 140 GB on the main hard drive of my computer so 512 GB was always almost empty. I save everything on a set of HDD which are in excess of 10 TB and arranged for different tasks.

I cannot put my pictures and documents next to operating system that always is subject to different issues. I also every now and then save my things on Blu rays. That I cannot find things on these things later is another issue that still has not been solved. I like other consumers of new technologies cannot hire a personal private IT person, and we know that even them are lost among the huge flood of data.

The highest usage of my main drive is for LaTex that I use MikTex and I am used to complete install of their packegs. I also have some in-house apache webserver, a Microsoft office and such.

I installed the Rayzen CPU, WD Green M2 SSD and the stock cooler that came with the processor on the bench. I used the antistatic bag of the motherboard as the anti static surface under the mother board during these installations.

I also installed four pieces of Crucial DDR4 2666 MHz (4x8GB the most expensive item in this build) at this stage.

Then I put the whole build in the case (Thermaltake suppressor F51). I already had attached the back plate. on doing the screws I noticed one screw was under the M2 SSD and left undone which was not important. Eight screws are enough. I paid attention on tightening the screws to prevent counter torques that can damage the motherboard.

I liked a fresh install with all the sufferings that I experienced when tried to use images of pf Windows that I had on previous hardware builds. I did not connect any HDD. Windows should be installed on the WD Green alone both for cations and also ease of    installation.

Windows ISO on the DVD's these days won't go easily with the M2 SSD's. So from the official Microsoft Windows 10 I downloaded a flash memory stick version of the Windows 10. I used my laptop for that job. When the download software asked me if it should add some details of the laptop I un-checked the box. I did not need it for the laptop, obviously. I used an 8 GB memory stick for the Windows image.

I also downloaded the latest version of the motherboards BIOS from the ASUS site. I have a separte dedicated marked memory stick just for updating BIOS.



Monday, 22 October 2018

I moved to AMD Platform part 1

Few years ago I decided to move to more powerful platforms at home to serve me longer and easily can be upgraded. Reason was that until that time I only used to use Intel motherboards. Well, before that I had IBM motherboards until IBM stopped to build those hardware and so I switched to Intel motherboards.

Actually my story goes back to Z80 and 8080 and these things. From that time there were people who spontaneously had selected Motorola 6800 instead of 8080. IBM took 4004 and then next generations of Intel's and developed DOS instead of CP/M. IBM made these two the winners but itself gradually left the arena.

When I noticed Intel would not build any motherboards of its own for non-server computers, still I could not use AMD. I was not familiar with their CPU's.

Then I wondered which socket of Intel was more promising than the others. Intel vastly was promoting socket 1366, but suddenly announced that there was an error in creating that socket and no further development would be possible

At the same time Intel marketed socket 2011. I found the idea of having 2011 pins on a microprocessor very stable and promising and also very exciting. I could remember there was a time, an ancient time, that we called a TTL with 24 pins a millipede.

As Intel did not build any motherboard for this socket, after some search I decided to move to ASUS. Well, Gigabyte and MSI and others are also good enough, but ASUS has some reputation I liked to test. When I bought my (Intel chipset) X79 motherboard from ASUS, immediately I noticed that its accompanying CD was outdated in terms of Windows.
True, they had all updates on the motherboard site. But, as I also sent an email to them, it was better if instead of that or on the side of that they put an updated ISO image. Then you can burn  it and use it as the motherboard accompanying DVD. That could make me happy; having the latest ISO

It is still advisable if they do that for their new boards with so many fuss that they have about their Republic of Gamers, etc., etc. They can put also an image of the sticker that you need to put on the DVD such that you download and print it make a DVD  similar to what was with the motherboard.

Immediately after I finished my build, Intel announced that they would discontinue socket 2011 and marketed a 2011 v3 instead, not compatible with 2011. So my new build fell in the blind end.

I, like many other IT power users/enthusiasts who had chosen socket 2011, continued using my build. The important point was the front side speed that was almost similar on all sockets. For example, my G.Skill 2400MHz memory cards worked on 1333MHz, not even nominal 1600 MHz of X79.

From 2016, front side speed witnessed a new upgrade. DDR4 memories with new specs replaced DDR3 and we know that they create a new realm not compatible with DDR3 memories. They can push fsb further. Now they talk of 5000 MHz and above for memory (though most of the people who buy those high end memories cannot tune them and memories roll back to 2400 and so). Chipsets need to run faster fsb and these chipsets are still working around 2400-2666 MHz.

With these in mind, and considering that Intel does not have a clear roadmap to be economically feasible for average users (who pays £1800 for a CPU and after a year found it obsolete), I suddenly decided to move to AMD platform. I focused on new low price low power consuming Rayzen platform completely unlocked for overclocking.

I found two platform X370 and X470 accommodating these CPU's.
First I bought an ASUS X370 with a Rayzen 1600 CPU. Unfortunately, with my 512 GB SSD the system randomly would go to the hibernate state and would not wake up, with freezing shut down and reset button. I had to turn off the PSU externally and turn it on back to reboot the system.

Before it becomes late I returned them to seller and refunded my money (I paid £9 for shipping via Parcel Force).

ASUS X370 was flimsy and cheapie and could not be compared with my ASUS Sabertooth I had

X470 boards have a better promise for future upgrades of Rayzen. So I ordered one of them and a better specs Rayzen 2600. I also got a WD Green M2 240GB SSD.